CWオーディオアクティブフィルタの動作確認

抵抗がいろいろ届いたので、CWオーディオアクティブフィルタの実動作を確認してみる。

ターゲット周波数は800Hz。ちょっと高い気もするけど、TS-690のサイドトーンが800Hzなので、とりあえずそれに合わせる。

シミュレーション

中心周波数は793Hz(実機では少し上がる傾向なのでそれを見越して)。通過帯域幅は、144Hz。先日の計算結果を使うが、ゲインが4dBではちょっと大きい気がしてきたので、2dBに抑える。

フィルタの入力の抵抗(上の図では、R1とR4)をE24系列で一段動かすと(通過特性は変らずに)ゲインが1dBずつ動く感じ。片方で1dB。両方動かせば2dB。ということで、以前の計算結果から、それぞれ一段ずつ上げてゲインを2dBにしたものが上のシミュレーション。

実測

入出力波形。

下が入力、上が出力。位相がほぼ反転してしまっている(前からわかっていたことだけど)。

周波数特性。

中心周波数は820Hzくらい。思ったより上にずれた。

中心部付近だけを再スキャン。

入力電圧を調整して、ピークのところが0dBになるようにした。中心付近がフラットにはらなずに山型になってしまっているため、-3dBのところは790Hzあたりと870Hzあたりで幅は約100Hzと、シミュレーション結果よりも狭くなってしまっている。

聴感

無線機のフィルタ帯域は2.4kHz。オーディオフィルタをON/OFFして聞こえ方を確認。

CWオーディオアクティブフィルタ 800Hz

ま、こんなものかな?

課題

フィルタON/OFF時のノイズ対策

スピーカだと気にならないけど、ヘッドフォンだとポップ音がでかい。さて、どうしたものか?

アンプの電源を入れた際のデバイススキャン

アンプ部の電源を切れるようにしているのだが、その電源を入れた際に、Windowsのデバイススキャが走ってしまう。結果、CH340GのRTSとDTRがバタつき、CWとPTTがON/OFFされてしまう。

電源供給をUSBからではなく(PCにつながない)、ACアダプタからにした場合には、アンプの電源を入れてもこの現象は起きない。なので、Windowsが検知しているのだと思う。アンプICの電源をON/OFFしているだけなのに、なんでWindowsがそれに気づく?

アンプの電源を切るのは諦めるか?HT82V739にはCE端子があるので、電源を切る代りにCEを使ってスタンバイモードにしてみるか?これで、WindowsのUSBスキャンが走らないことを確認。

USBモジュールのコネクタの強度が不足

MicroUSB端子を使いたかったので、制御チップと一体になったモジュールを試してみた。動作はいいのだけど、機械的に弱すぎる。USBコネクタにちょっと大きめの力が加わると、パターンごとはがれてしまう。どうも、このモジュールのUSBコネクタの取り付けパターンがよろしくないようだ。RTSとDTRの両方が取り出せるモジュールはなかなかいいのがない。

諦めて、USB Type Bコネクタを使うか。これなら、スルーホール仕様のコネクタが普通にあるので強度の心配はない。ただし、CH340Gはチップ部品。とはいえ、1.27mmピッチなのでハンダ付けは難しくはないだろう。あとは、USB Type Bだとコネクタが大きくなってしまうので、土地の問題が生じる。なんとか入るかな?

スイッチの配置

ヘッドフォン/スピーカ切り替えスイッチが悪い。ヘッドフォンプラグを差し込むとスイッチ操作が難しい(指が入らない)。ジャックとスイッチの場所を入れ換えよう。

パネル

前面パネルだけにしようかと思っていたけど、裏面と側面のパネルもあった方がやはりいいだろうなぁ。しかし、角にRを付けると、四隅には隙間ができてしまう。「実用上問題はない」とするか?それにしも、ますます土地が狭くなる…。果たして、部品は載るのか?

スポンサーリンク
スポンサーリンク