NanoVNASaver 0.3.8

新しいバージョンが出たようだ。

変更点を引用。

– Allow editing of bands above 2.4GHz
– Restore column layout on start
– Support for Nanovna-F V2
– Fixes a crash with S21 hack

普通のNanoVNAやNanoVNA-H4を使っている者にとってはあまり関係ないかな?

ま、ともかく、試してみる。

普通に使える。当たり前か。測ってみたのは、460MHz位が共振周波数の実験用のLCR共振回路

それよりも気になっていたのは、Segmentsの指定。

ここを「1」以外にすると、0.3.7はクラッシュしてしまっていた(Sweepするとエラーを吐いてコケる)。これが直っていることを期待したのだけど、0.3.8でもダメだった。結構致命的だと思うのだけどなぁ。やってみればすぐに分かるだけど、対応されないとうことは、私の環境だけ?0.2.2などではちゃんと使えるんだけど。

この記事のタイトルとURLをコピーする
スポンサーリンク
スポンサーリンク
スポンサーリンク

コメント

  1. JH4AWD より:

    私の環境では1でも5でも10でもちゃんとスイープしますねえ。
    ただ、0.3.Xになってから色々な動作が私の感性に合わないので0.2.2をずっと使ってます。
    nanoVNAとの通信をミスってるのか?接続してnanoVNAのスイープ設定を読み込む時に28MHzになってしまうし、nanoVNA側のモニター表示が更新されなくなったり、急に更新されたり・・・
    Segmentsの設定が立ち上げる毎に1にリセットされてしまうし・・・
    1度0.3.8でnanoVNAと接続してしまうと電源ON/OFFするまでnanoVNAがおかしな動作をするので変なデータを書き込んでるのではないかと思えます。

    • jh4vaj より:

      ありがとうございます。クラッシュはやはりこちらの環境依存のようですね。クラッシュしたときのコンソール画面をお見せしようと思い、今やってみたらSegmenstは5でも10でもちゃんと動いてしまいました。NanoVNAのファームウェアは0.7.0と0.8.0の二種類(物理的に二台)の両方で上手くいきました。加えて言うなら、PCの電源はずっと落としていないので「再起動で~」という話でもないですし。不思議です。

      それから、NanoVNASaver 0.3.xではおっしゃる通り、周波数範囲やSegmentsの値が強制設定されてしまうようですね。Connect to deviceを押して接続した瞬間に決め打ちされている感じでしょうか?また、NanoVNA本体のスキャンが止まるのもConnect to deviceを押したタイミングです。PAUSE SWEEPが強制設定されるようです。これをタップして解除すれば、本体側はスイープを始めます。が、NanoVNASaverのSweepボタンを押すと、また強制的にPAUSE SWEEP状態になります。また解除すれば良いのですが、面倒です。

      0.2.2でも通常使用には問題ないのですけど、NanoVNA-H4の画面をキャプチャできないのがちょっと困ります。まぁ、これも0.2.2のソースコードを持ってきてパッチを当ててコンパイルすればH4の画面もキャプチャできるようになりますが。

  2. 隠れウォッチャー より:

    NanoVNA SaverでErrorが発生してましたが(2台Win10)
    レ点を外したら2台ともソフトがうまく動作しました。

    試したのはVer.0.2.2-1です。左下Manage→Settings→Validationレ点を消す→Refresh
    クリック以上で私は動作しましたがいかがでしょうか。

    *的外れコメントでしたら削除願います。

  3. たからべけん より:

    Segmentを1以外するとクラッシュする件、、自分のNanoはクラッシュしないので”ふーん”、、とスルーしていましたが、突然発症しました。NanoVNAもH4も同様、、0.3.8でも0.3.7でも0.2.2でもダメ、、発症前後で環境を変えた心当たり無し、、唯一思い当たったUSBケーブル、、実はDAISOの1mケーブルを使い始めました、 そんな馬鹿な、、と思いながらオリジナルのケーブルに戻したところ見事に復活、、、どちらも大陸品質で納得いきませんが、DAISOのはオネイチャンがスマホ充電するためのでUSBと思っちゃダメということですか?オリジナルケーブルでも”タマタマで再発症しない保証”は無いのですが。
    もう一度DISOにして再発症を確認する気力はありません。

    • jh4vaj より:

      もしかしたら、充電専用ケーブルなのかもしれませんね。うちにも、micro Bですが、充電にしか使えないケーブルがあります。

  4. たからべけん より:

    充電専用ケーブルにしてはSegmentが1の場合問題なく作動するのが面妖、、充電専用ではなく、”充電に使うのが無難ケーブル”なのかも??USB接続ってシビアでクリチカルな物なのか?? マアあれだけの情報量を一瞬でPCへ転送するので1200bpi世代の爺には理解を超えています。

    • たからべけん より:

      “1200bpi世代の爺”ではなく、”1200bps世代の爺”でした。耄碌したくない。

  5. 先日、nanoVNA-H4を購入し貴HPの分かりやすい取説により、無事本体の設定が完了し、アナライザーとして十分に活用させていただいています。ありがとうございます。
    しかし、nanoVNA-Saverを起動しても、PC(WIN10)と接続できません。
    COMポートを認識してくれないようです。(COMポートが表示されない。)
    PCは、WIN7をWIN10にバージョンアップしたものと、最近購入したWIN10の2台がありますが、共に同様の状態です。
    貴局での再現はできないと思いますが、何かアイデアがありましたらお知らせ願います。
    JA9NOF

    • jh4vaj より:

      PCにつないでもCOMポートに現れないとのことでしたらNanoVNASaver以前の話ですよね。しかも、二台のPCで試して同じとのことですから、NanoVNA-H4のハードウェアの問題でしょうか。思いつくのは、USBコネクタのハンダ不良あたりですが、確証もないですし、対処も大変そうです。私なら、初期不良として販売元に問い合せます。

      • JA9NOF より:

        早速ありがとうございます。
        自動認識が普通の件、了解しました。
        休みの間に、問い合わせてみます。

        • jh4vaj より:

          問合せは早めの方が良いかと思います。向こうも休みに入ってしまうと回答が遅くなるでしょうから。

          • JA9NOF より:

            アマゾンの質問コーナーで、何度かやり取りし、「別のPCでの動作確認してくれ」と言って来たので、「最初の質問時に連絡済み」と回答したら、2月8日に1セットが送ってきた。今度はPCと接続できました。お騒がせしました。次回からは送付されたらすぐに動作確認します。これからPC操作側の勉強です。ありがとうございました。

          • jh4vaj より:

            色々大変だったようですね。でも、何とか解決したようで良かったです。どうぞ使い倒してください。